when editing PM/topic title: no longer able to add ticket priority, status, reason tags

when editing PM/topic title: no longer able to add ticket priority, status, reason tags
0

Environment

Discourse Version: latest-release +173

Plugin Commit: bedb584

Other Plugins
babble d8df91b Up to date
Official Plugin discourse-akismet cfdb57d Up to date
Official Plugin discourse-assign 6d3bc3e Up to date
Official Plugin discourse-bbcode-color 183aab8 Up to date
discourse-bcc d205b9c Up to date
Official Plugin discourse-cakeday 0ada90e Up to date
Official Plugin discourse-canned-replies 5f435d7 Up to date
Official Plugin discourse-checklist f22ae7b Up to date
Official Plugin discourse-data-explorer 16ea1c5 Up to date
discourse-events 63e7a38 Up to date
discourse-knowledge-explorer cf0d3d6 Up to date
discourse-send-private-message 0dc72c0 Up to date
Official Plugin discourse-saved-searches 8dd8634 Up to date
Official Plugin discourse-solved 230c207 Up to date
Official Plugin discourse-user-notes 339cd31 Up to date
discourse-team-timezones e876b03 Up to date
discourse-tickets bedb584 Up to date
Official Plugin discourse-translator 037b03e Up to date
Official Plugin discourse-voting ec32749 Up to date
Watch Category 659182e Up to date
discourse-whos-online 54257b6 Up to date
Official Plugin discourse-yearly-review 41b2382 Up to date
Official Plugin docker_manager 2c89085 Up to date
retort d2eb118 Up to date

Steps to Reproduce

Edit topic title. Usually you can use the pulldowns to choose priority, status and reason tags. These are now empty. No relevant info I can see in the error log.

Example

any topic. requires mod privs.

Logs

no relevant log info

I wonder if it has to do with this bug: Red warning when adding tags, unable to add tag "en.select_kit.max_content_reached" - bug - Discourse Meta

Update - the bug I reported on meta has apparently been fixed but there are still some tags not showing up for me on my site. Not sure what’s going on but will keep this topic updated… if anyone has any suggestions or fixes I’d be grateful.

This issue is still ongoing on both of my sites, though the folks at meta say they have fixed what I was assuming/hoping was the underlying issue (and subsequently deleted my topic there reporting the bug), purportedly in collaboration with Angus.

Any advice, @angus, on where I should look next?

I think I ran into the same thing, which I posted below before thinking to come here:

1 Like

I’ve raised a pull request which I believe fixes this:

1 Like

@tobiaseigen, @downey et al if you are feeling brave, you could test this out (it can’t be any worse, right? :wink: )

But you will need to rebuild to this fork:

(which is identical save it contains the fix already)

1 Like

ok - I switched to this fork and rebuilt on my personal site, and it seems to be working! :rocket:

nice job and many thanks!

1 Like

np, as you can imagine Angus can get swamped when a big core change occurs, glad to help.

Thanks for testing!

1 Like

Unfortunately I only have this running in production so unable to test until the changes are merged in. But if it works for @tobiaseigen I think it’ll work for me too. I will test promptly and confirm that once able to update the plugin.

2 Likes

np @angus should be on in a few hours in any case.

2 Likes

I applied this fix to the global legal empowerment network forum too - looking good so far. :+1:

2 Likes

I swapped over to this fork of the plugin and the problem is resolved on the ticket interface. Thank you!

However at /admin/tickets I am still seeing the same problem in the drop-down with them being empty. @tobiaseigen can you repro?

(Would it be much of a risk to stick with this fork, or should I switch back?)

1 Like

I do not use that interface at all at the moment. I can check tomorrow.

1 Like

I’ve gone ahead and FIXED that too on the Pavilion Fork as of:

Just update if you are already using the Pavilion Fork.

2 Likes

(It works; thanks!)

2 Likes