url field can't be empty


Discourse Version: 2.7.0.beta4 ( 47835ade9a )

Plugin Commit: 2bca82a

Other Plugins
babble ea961a4 Up to date
discourse-akismet a58d614 Up to date
discourse-cakeday 1375bd8 Up to date
discourse-canned-replies 46ef2d1 Up to date
discourse-custom-wizard 2bca82a Up to date
discourse-data-explorer 4f33c22 Up to date
discourse-locations d95c1bb Up to date
discourse-oauth2-basic 0be01f0 Up to date
discourse-patreon 3bd47eb Up to date
discourse-spoiler-alert ada31aa Up to date
discourse-user-notes 300b279Up to date
discourse-whos-online 35c814b Up to date
docker_manager f630767 Up to date
retort b8716bf Up to date
styleguide Up to date

Steps to Reproduce

  1. Create a wizard with a step and some fields
  2. Make one field type a URL
  3. Run the wizard, but leave the URL field blank

Hit next/done and get the error “Video link must be a valid url”


member only site


Another good report.

Yes, this is actually a known issue, i.e. the url field type is effectively a “always required” field type, regardless of the “required” setting.

You’re finding all the things I had made of note of to fix one day and had forgotten about :sweat_smile:

This should be fixed now

1 Like