UI bug when using QA from Mobile

Environment

Discourse Version: beta9.2.4.0

Plugin Commit: latest master

Other Plugins
discourse-akismet 0.1.0
discourse-math 0.9
discourse-question-answer 0.3
discourse-sitemap 1.2
discourse-solved 0.1
discourse-voting 0.4
docker_manager 0.1

Steps to Reproduce

Create a new QA topic and add some answer that contains Math equations (not sure if its due to the math equations). Take a look at the post from the mobile. You will see that the post is going out from the frame and you can’t fully read the text.

Example

I can share a live example by PM (currently we want to keep the community private). So if you want to see a live example, please PM me.

Logs

Hi Pavilion team!
A small update - it’s been a few days and I didn’t hear from you guys so I have to uninstall the plugin from our instance. That’s ok! I understand that you guys are overloaded with paid tasks and plus its holidays now :slight_smile:
I uninstalled the plugin because currently it isnt possible to read the posts from the mobile. Also I found out more bugs that I wanted to report after this bug but I feel like it will just destruct you guys.
Anyway, I saved some screenshots of the issue. Please PM me if you want to check it.
I hope to return in the future to the idea of moving the forum to be QA but it too early for that
Good luck and happy new year to everyone :slight_smile:

Another small update if you may (not sure why you ignore this topic, at least recognize it).
I thought of putting some effort in investigating the issue. I think I have managed to reproduce it in the sandbox. I see it as:

You don’t see the buttons like flag and edit (you can’t scroll right).
It looks like the issue is due to the following line:

In my case, I have a RTL community so it could be also the issue.In any case, this bug happens in two cases - long section of code or lone multi-line mathjax equation. Discourse solved it by wrapping the section with scrollbars but when I use the QA plugin, it stops working.