Topic List Previews not setting og:image <meta> tag

Environment

Discourse Version: 2.5.0.beta4

Plugin Commit: 90598e1

Other Plugins
discourse-canned-replies 8cf0285
discourse-data-explorer 2c11e38
discourse-events ee511fa
discourse-fingerprint c91883f
discourse-paid-pinning ec9a04e
discourse-user-notes 41861b5
discourse-whos-online 561f84a
discourse-yearly-review 41b2382
docker_manager 286afef
garmin_connect_onebox 0dc5a49

Steps to Reproduce

Create a new topic with a single post featuring an image.

Open topic in new browser and view source.

Example

I expect the og:image to be https://se26.life/uploads/default/original/2X/e/ec3703d6a87436fa24bc97aad72a417e89548d94.jpeg

but instead it’s the site logo (the default og:image)

Logs

Thanks for the report. Currently the plugin is all over the shop due to big changes in core. I’ll be looking at it before month end for sure.

Going forward the plugin will get less involved with image setting as Discourse have now created thumbnailing logic.

That said, it would be nice to retain the thumbnail picker.

2 Likes

Discourse Core’s logic doesn’t seem to work though?

1 Like

If the og tag for a Topic does not include the image that exists in the thumbnail record, then that’s a Discourse, not TLP bug.

TLP affects the Topic List presentation. It is not really intended to change Topic behaviour except for potentially updating the Thumbnail to one that you can choose yourself.

exact same issue here,I just added an issue on github before finding this.

1 Like

Have you tested this without TLP? And confirmed it works. If not, it’s not TLP.

To my understanding, no TLP - no thumbs. This is after enabling, should have the default thumb url but its missing.

image

1 Like

Thumbnails are now generated by Discourse. Have been for a couple of weeks or so now.

I’ve turned off thumbnail generation and serialisation from latest TLP and will rely on Discourse Core going forward.

If you are using the TLP plugin you need to add my simple TC to initiate the Discourse production.

Latest update is here:

All that said I will join you in checking this to see if I can see an issue in core Discourse.

Bottom line: if there is no og thumbnail tag for a Topic it’s something Discourse may have overlooked. I’ll raise with them if I can reproduce.

TLP was never involved with that process. image_url field was always a core Discourse field

As a test, here’s a share from my local community website … seems to work:

Thanks for the super quick response. I tried your theme-component and the latest version of TLP with discourse beta4. nothing seems to work.

Found the topic thumbnail theme component which seems to work now but at the sacrifice of featured images and replacement thumbnails.

I think I didn’t explain myself properly I was expecting the post previews on the home page.

why not here goes iabroad.co

There are now two setups:

  1. Standard, Plugin based one - now requires a mini TC to initiate thumbnailing. This is currently supported but I aim to decommission it at some stage and will replace it with 2:
  1. TC based, experimental, expect issues … optional plugin sidecar that adds features

Sorry for any confusion on different setups

2 Likes

I’m confused for sure :smile:
Thanks for the support. Just dont want to loose any pavilion plugins ,its fuel to my site :wink:

1 Like

Yeah, its confusing that there are two Theme Components.

One is a massive one that will likely replace the Plugin at some stage. There is a smaller addin plugin you can add to get more features.

The other setup is the existing plugin. But now requires a tiny Theme Component to work.

We’re in a transition period.

Don’t worry, I’ll be supporting it.

So, suggestion for you is:

  1. Update existing plugin.
  2. Add new mini Theme component. Refresh your page. Thumbnails will take time to generate.

I will leave it for now and wait for the next update. As long as the post has an image everything seems to work fine so no rush. :slight_smile:

Update is live as of yesterday.

There may be bugs, but they won’t be related to the og tagging as that’s core Discourse functionality.

All started after last night’s upgrade :upside_down_face:

tlp

still no luck

Have you refreshed your webpage?

One more thing: I noticed that the repo link was wrong in the OP on Meta!!

It should be this:

i think this is the issues, I was using Angus’s repo all this time :shushing_face:

I’m rebuilding now, lets see.

Great we got to the bottom of that! Since I took over the component its been sitting there like that!

sorry it didn’t work :frowning_face: