Required (but unchecked) checkbox fields are not highlighted when submitting wizard

@angus / @fzngagan - another minor issue with the wizard has come up in our QA.

Reproduction Steps:

  1. Create a wizard with a mandatory checkbox field.
[
    {
        "id": "checkbox_test",
        "name": "Checkbox Test",
        "save_submissions": true,
        "steps": [
            {
                "id": "step_1",
                "fields": [
                    {
                        "id": "step_1_field_1",
                        "label": "This checkbox is mandatory!",
                        "description": "",
                        "required": true,
                        "type": "checkbox"
                    }
                ]
            }
        ],
        "actions": [
            {
                "id": "action_1",
                "run_after": "wizard_completion",
                "type": "route_to",
                "url": [
                    {
                        "type": "assignment",
                        "output": "www.google.com",
                        "output_type": "text",
                        "output_connector": "set"
                    }
                ]
            }
        ]
    }
]
  1. Attempt to submit the wizard without completing the field.

Expected Behavior:
The checkbox shakes, with a red highlight, as other required fields do when not complete.

Actual Behavior:
The checkbox shakes, but is not highlighted in red as other fields are. This increases the chance it will be missed by users
https://streamable.com/otvhq7

Thanks for the report. I’ll handle this one.

@othomson If it’s ok with you, I’ll actually move this to #open-source:bug-reports.

Thanks, go for it!

Hi @angus - are you able to share a timeline for this?

We’re hoping to launch the wizard on the 3rd December and would like to fit this fix in if at all possible.

Working on this one (and will complete it) today

This one has been addressed

1 Like

Perfect, thanks Angus.

This topic was automatically closed after 3 days. New replies are no longer allowed.