Layout widgets don't show in Tags context

Environment

Discourse Version: 2.6.0.beta5

Plugin Commit: version 0.2

Other Plugins

Steps to Reproduce

  • Add the Tags context for Layout widgets
  • select any /tag/… or /tags/… view
  • the widget sidebar doesn’t show

Example

Logs

Thanks for this report, I can in indeed reproduce this and I’ve fixed it.

Thanks for looking into this! Updated to the latest commit and it works :slight_smile: But I saw there is two contexts: /tag/<any tag here> and /tags/none

Now tags/none gives me a Oops! That page doesn’t exist or is private.. I don’t know if it’s related to the change, but before it showed the topics without tag.

This is very helpful, thanks. The handling of the tags routes is tricky, and I don’t have any live examples I’m currently working with, so it’s been somewhat de-prioritised. In this case you’ve actually discovered a Discourse issue.

The none route is a special route that is only relevant if you have the show filter by tag site setting on and you specifically click on “no tags” in the tag dropdown. In all other circumstances, the router just removes the tags, rather than having a specific none route. Moreover, the handling of this special route is different if you’re in a category or the “top” context (i.e. without a category). You’ll notice the issue you’ve reported only presents if you’re not in a category. So the issue is:

  • show filter by tag site setting is on
  • in a non-category route
  • if you click on “no tags” in the tags dropdown.
  • the route doesn’t exist

If you repeat these steps on meta.discourse.org you’ll get the same result. You might want to report it as a bug on meta. Do a search first to see if it’s been reported before.

1 Like

Thanks for the explanation! I posted a bug on meta:

The /tags/ route no longer exists due to a core deprecation. Replace it with /tag/

Thanks! Just posted on meta that the navigation menu still directs to tags/none.

1 Like

This topic was automatically closed after 3 days. New replies are no longer allowed.