Date format not respected

Environment

Discourse Version: 55611a5b

Plugin Commit: 04f0085

Other Plugins
Official Plugin docker_manager a9114e5 Up to date
Official Plugin discourse-akismet fa4d0da Up to date
Official Plugin discourse-calendar 8844829 Up to date
discourse-custom-wizard 04f0085 Up to date
discourse-legal-tools a15193e Up to date
discourse-migratepassword 91d6a00 Up to date
discourse-simple-unread 7636ec9 Up to date
Official Plugin discourse-user-notes 31dcacb Up to date
plugin-check-email 71645cb Up to date
Official Plugin styleguide Up to date

Steps to Reproduce

I created a wizard with one field, set the format to be DD/MM/YYYY (also tried dd/mm/yyyy) but the wizard always shows mm/dd/yyyy when I run it.


Example

https://prod.ageplay.dk/w/opret-bruger

Logs

1 Like

Taking a look at this now.

1 Like

@nicolailang
This will need a comprehensive set of changes. I’ve confirmed the issue you reported.
There are some additional things to be taken care of too. We’ll discuss this internally and get back to you in a few days time.

2 Likes

@nicolailang
I’ve merged two PRs which should fix the issue you reported.

1 Like

Please do update and confirm everything is working correctly now.

1 Like