Compose Wizard not completing

Environment

Discourse Version: 2.6.0.beta1 ( 0b800d307f )

Plugin Commit: a0f2d85

Other Plugins
- git clone https://github.com/discourse/docker_manager.git
- git clone https://github.com/davidtaylorhq/discourse-category-lockdown.git
- git clone https://github.com/discourse/discourse-adplugin.git
- git clone https://github.com/angusmcleod/discourse-locations.git
- git clone https://github.com/angusmcleod/discourse-events.git
- git clone https://github.com/jannolii/discourse-topic-trade-buttons.git
- git clone https://github.com/davidtaylorhq/discourse-whos-online.git
- git clone https://github.com/discourse/discourse-canned-replies.git
- git clone https://github.com/discourse/discourse-akismet.git
- git clone https://github.com/angusmcleod/discourse-knowledge-base.git
- git clone https://github.com/paviliondev/discourse-multilingual.git
- git clone https://github.com/discourse/discourse-translator.git
- git clone https://github.com/paviliondev/discourse-custom-wizard.git
- git clone https://github.com/discourse/discourse-zoom.git
- git clone https://github.com/Ebsy/discourse-nationalflags.git
- git clone https://github.com/discourse/discourse-calendar.git
- git clone https://github.com/discourse/discourse-fontawesome-pro.git
- git clone https://github.com/merefield/discourse-topic-previews.git -b “theme_sidecar”

Steps to Reproduce

I have a wizard that opens the composer with the body of the topic filled out. Some users are having an issues where when they create the topic much of the text in the body is missing. It’s not one user making a mistake as it happened to several people. But I cannot reproduce it myself. In the logs all of the text shows up, but it’s not in the post. Here is an example of one that failed:

wizard: image_critique; action: open_composer; user: Bonnie_Lampley; info: route: /new-topic?title=Trouble%20in%20Paradise&body=In%20honor%20of%20COVID-19.%20%20I%20made%20this%20right%20at%20the%20beginning%20of%20lock%20down,%20but%20wasn't%20thinking%20specifically%20of%20that.%20%20After%20the%20fact,%20it%20occurred%20to%20me%20that%20this%20was%20apropos%20for%20the%20current%20situation.%20%20%20If%20anyone%20wonders,%20this%20is%20spring%20mustard(?)%20shot%20through%20last%20years%20star%20thistle.%20%20%0A%0A![Trouble%20in%20Paradise](https://assets.naturephotographers.network/original/3X/1/7/17d7c0a120718ab053a55b3989ffca51428d748e.jpeg)%0A%0A%23%23%23%20Specific%20Feedback%20Requested%0AAny%20comments%20welcome.%20%20%0A%0A%23%23%23%20Technical%20Details%0Aa73r,%20105mm,%20f/4,%201/200s,%20ISO200,%20hand%20held.%0A%0A@bonnie_lampley&category=image-critiques/landscape-critiques/5&tags=ig - 

Another:

wizard: image_critique; action: open_composer; user: Dennis_Plank; info: route: /new-topic?title=Pacific%20Jumping%20Mouse&body=I%20was%20in%20my%20bird%20blind%20a%20few%20days%20ago%20when%20I%20saw%20motion%20at%20the%20back%20of%20my%20ground%20pool.%20%20It%20turned%20out%20that%20it%20was%20this%20mouse.%20%20Initially,%20it%20was%20eating%20a%20blade%20of%20grass,%20then%20it%20went%20down%20to%20the%20pool%20very%20briefly%20before%20something%20seemed%20to%20startle%20it%20(perhaps%20a%20bird%20coming%20in).%20%20It%20didn't%20seem%20bothered%20by%20the%20sound%20of%20the%20shutter.%20%20%20%20The%20ID%20is%20somewhat%20tentative,%20but%20I%20have%20other%20shots%20showing%20part%20of%20the%20tail%20(too%20long%20for%20a%20vole)%20and%20one%20of%20the%20hind%20legs%20(too%20long%20to%20be%20much%20else).%20%20The%20problem%20I'm%20having%20with%20the%20ID%20is%20that%20the%20books%20say%20there%20should%20be%20%20a%20sharp%20demarcation%20between%20the%20color%20of%20the%20back%20and%20that%20of%20the%20sides,%20and%20I'm%20not%20seeing%20any.%0A%0A![Pacific%20Jumping%20Mouse](https://assets.naturephotographers.network/original/3X/9/d/9d8a46fd714c221d959ddd0127b3034ec277af6c.jpeg)%0A%0A%23%23%23%20Specific%20Feedback%20Requested%0AIs%20the%20out%20of%20focus%20foreground%20rock%20on%20the%20right%20too%20much?%0A%0A%23%23%23%20Technical%20Details%0A7DII,%20Sigma%20150-600%20C%20@%20546%20mm,%20tripod%20with%20ball%20head%20and%20Sidekick%20mount,%20f/8,%201/400,%20iso%202000,%20manual%20exposure.%20%20Processed%20in%20LR%20&%20PS%20CC.%20%20Cropped%20from%20the%20right,%20full%20height.%0A%0A&category=image-critiques/wildlife-critiques/12&tags= - 

Example

I’m unable to reproduce. Once you have time to look into this I can set it live on the site again if we need others to test it.

Logs

n/a

Hi @angus, sorry to bug you but I’m curious if this is being looked at? It’s preventing me from using the wizard at all, along with the component Rob created for me. Thank you sir.

I can’t repro this one either unfortunately. Here’s a test wizard: Open Composer Test.

If you can repro this reliably yourself, I can take a closer look. I know it may seem a bit unlikely, but there are a few possibilities here, e.g. user is inadvertantly removing the content, or has a browser extension that does so.

We have to be able to reliably repo it.