Can't get the Events plugin to load at all

Environment

Discourse Version: 2.4.0.beta10

Plugin Commit: 0.1

Other Plugins
the bug occurs with all other plugins and components switched off

so it would be the ‘light theme’ and ‘Docker-Manager’ as i can’t turn that one off.

Steps to Reproduce

Installed. Can’t see any options for using the calendar.

There’s a discussion in the comments with everything that was tried over here: Events Plugin 📆 - plugin - Discourse Meta

Example

I suppose on that link, as the category has Events set up, but nothing shows as being active there. There is a lot else going on in the live forum though. The calendar doesn’t show up with everything else switched off.

Logs

1 Like

edit: it does show the links in the burger menu, just not in each category where its turned on, and we aren’t able to create an event although we can see the calendar

So creating a post, saving it, then editing it you do not see the add event button near the top?

Currently, it works for the category its switched on for. Please confirm that.

This is how i’ve switched it on. if there is another setting then i’ve missed it. (i’ve tried setting the min level to 1 also).

image

All plugins and components are off except for one-signal and docker manager, which don’t have an options to disable.

If i click edit on a post i see this:

or this if i’m editing the text of the post

or this if i’m using the admin tools to edit something:

image

None of these mention a calendar.

The calendar itself is available in the burger menu and takes me to the calendar page, but i can’t see any option to create events

image

1 Like

If you can give us temperory admin access, we’ll take a look.

1 Like

sure. i’ve just turned all the plugins back on but i have permission to make you an admin. have you made an account already? I see Tobias, are you there also @fzngagan

i can turn them back off if you’d prefer. its still possible i’m making a very basic error as i didn’t find documentation to follow when setting it up.

1 Like

I’d be happy to take a look - am logged in now.

I’ve just made you an admin. Sorry I went to walk my dog

1 Like

Hi Andy! I had a poke around and can replicate the issues you are describing. I also compared the settings with my own site and tried a few things…

  • added trust level override to category - changed from blank and added default time zone, set to UTC, and set events timzone display to “event timezone, if set” (to no effect)
  • tried safe-mode, with plugins still enabled but custom theme disabled (no effect)
  • enabled devtools in chrome, see no related errors (but don’t necessarily know what I am looking for)
  • looked in the discourse error logs, see no related errors (but don’t know what I am looking for)

On my site, I actually see the ability to add event details when adding a new topic in a category with events enabled - see screenshot and calendar icon to right of tags input.

As a next step, I’d recommend you rebuild from the command line and get everything updated to latest. If that does not work, then you will need to start looking at conflicts with plugins and customizations.

Good luck!

2 Likes

thanks for doing that for us @tobiaseigen. i’m not sure where to look next to try and fix this as we just uninstalled and reinstalled from command line, and that doesn’t seem to be the issue. unless you mean our entire site.

the only remaining plugins it could be are:
docker-manager and one-signal. we pipe our site through cloudflare, is it possible that’s causing it?

Just try a

cd /var/discourse
./launcher rebuild app 

And see what happens.

Why do you do that? I think cloudflare can indeed lead to unexpected behaviors, as you know. If rebuilding doesn’t help you could look at your cloudflare settings and maybe disable it.

Can you try this? Disable global event settings and then disable event settings from the category, save changes, and then enable them again? Would be interesting to see if that works.

1 Like

Strange. That did half work. I disabled global settings and only enabled it on category level and now i see this:

but still can’t create an event.

I don’t have command line access and the sys-admin team in our community is a bit thin right now. there should be someone who has it online tomorrow and we’ll try the reset. Thanks for your support in tracking down this bug. I can disable cloudflare, trying it now.

With cloudflare off and all plugins and components off (besides the two i mentioned before which don’t have an off switch) it’s still in the same state, the calendar and agenda tabs now appear (with global settings off and only category specific ones on), but i still can’t create an event.

Hi Andy! I had a look and see I still have admin access. I got it working, it seems. Took a look through your settings, and it was disabled on the category… when I enabled it, the add event button is present when adding a topic. Try it out.

1 Like

thanks @tobiaseigen. i still don’t see it. i turned all the plugins back on, but that was a bit before your message. can you still create events? would you mind making one and posting a link here?

my screen is a bit small 12.5 inches maybe thats the issue?? (Discouse seems to hold its size when i force change the size of my screen)

Maybe you just need to do a hard refresh in your web browser? Event is here:

and screenshot of what I see when I start a new topic in that category follows. Note calendar button next to tag input.

2 Likes