Can't apply Add to Group conditionally

Environment

Discourse Version: 5e24436454

Plugin Commit: 500c305

Other Plugins
discourse-data-explorer
discourse-events
discourse-oauth2-basic
discourse-plugin-linkedin-auth
discourse-zoom
docker_manager

Steps to Reproduce

When I try and use a Wizard Field (Group) to apply conditionality in the Add to Group part, it doesn’t actually apply the changes I’m seeking.

Example

https://healthforum.nz/admin/wizards/wizard/welcome_step_2

This seems to be easily selectable, but doesn’t apply the group adding that I think it should.

If I use ‘=’, it doesn’t work.

@Nathan On the issue with adding to groups, I just tried this out on healthforum.nz and it worked for me.

Test:

  1. I make myself a member of the broad professional group “All Students”.

  2. I select “Medical Students” in the dropdown.

  3. As per the action, I am added to the https://healthforum.nz/g/a-medical-students group (i.e. the group I selected.

You can see the log of this action in the logs: https://healthforum.nz/admin/wizards/logs

Can you give me an example of it failing?

The regex issue (i.e the issue with =~) is a seperate one, I’ll create a seperate ticket for it

Yeah, whoops - I changed the wizard after posting that sorry!

OK, I’ve put it back now as it was when the error occured and set it aside for you:

https://healthforum.nz/admin/wizards/wizard/group_action_cond

This is how the Action step looks - I am trying to add two groups when one was selected in the wizard field. Piggy backed if you will.